The script

SpamAssassin and amavisd-maia both rely on a number of Perl modules and system utilities to function properly. You can use the script to verify that you have all of the necessary modules and utilities installed, and that their versions are new enough to be both useful and secure. You'll want to run this script on all of the machines where you run SpamAssassin and amavisd-maia.

While amavisd-maia, Maia's Perl scripts, and SpamAssassin will likely work with some older versions of these components, often there are security vulnerabilities in older versions that make it possible for attackers to bypass or cripple your spam and virus filters, so it's strongly advised that you keep these components up to date. With each new release of, we update the minimum version numbers of the various components, taking into account the latest published exploits, so you should not be surprised to see that the minimum version numbers for a given component have gone up since the last release. (See NOTE #2 below, however.)

If the script recommends that you upgrade or install a Perl module or utility, do so, and then re-run the script to make sure. The output should look something like this:


This script checks for the presence of applications and Perl modules
required by amavisd-maia, SpamAssassin, and Maia Mailguard's maintenance
scripts.  Version numbers are also checked, and if a newer version of
a component is recommended, you should consider upgrading to at least
the minimum recommended version.

If you have already configured your Maia Mailguard database, the script
will also test the connection to that database.

Remember also to run the configtest.php script on your web server to
perform similar tests of your web, PHP, and PEAR environment.

Application/Module      Version   Status
Perl                 :    5.8.3 : OK
file(1)              :     4.16 : OK
Archive::Tar         :     1.10 : OK
Archive::Zip         :     1.16 : OK
BerkeleyDB           :     0.26 : OK
Compress::Zlib       :     1.41 : OK
Convert::TNEF        :     0.17 : OK
Convert::UUlib       :     1.06 : OK
Crypt::Blowfish      :     2.09 : OK
Crypt::CBC           :     2.12 : OK
Crypt::OpenSSL::RSA  :     0.22 : OK
Data::UUID           :     0.13 : OK
DB_File              :    1.810 : OK
DBD::mysql           :   3.0002 : OK
DBD::Pg              :     1.31 : OK
DBI                  :     1.50 : OK
Digest::MD5          :     2.33 : OK
Digest::SHA1         :     2.07 : OK
File::Spec           :     3.01 : OK
HTML::Parser         :     3.35 : OK
HTTP::Date           :     1.46 : OK
IO::Stringy          :    2.109 : OK
IO::Zlib             :     1.03 : OK
IP::Country          :     2.20 : OK
LWP::UserAgent       :    2.032 : OK
Mail::Address        :     1.64 : OK
Mail::DomainKeys     :     0.80 : OK
Mail::Internet       :     1.64 : OK
Mail::SpamAssassin   :    3.1.1 : OK
Mail::SPF::Query     :  1.999.1 : OK
MIME::Base64         :     3.05 : OK
MIME::Parser         :    5.420 : OK
MIME::QuotedPrint    :     3.03 : OK
Net::CIDR::Lite      :     0.15 : OK
Net::DNS             :     0.57 : OK
Net::Server          :     0.93 : OK
Net::SMTP            :     2.29 : OK
Pod::Usage           :     1.16 : OK
Template             :     2.14 : OK
Time::HiRes          :     1.61 : OK
Unix::Syslog         :     0.99 : OK
URI                  :     1.31 : OK

Database DSN test    : PASSED

NOTE #1: The script only tests the amavisd-maia, Perl script, and SpamAssassin part of the Maia Mailguard system. The web server, PHP, and Smarty portion should be tested with the configtest.php script, using a web browser.

NOTE #2: If you use a package-management tool like yum, apt-get, etc., your package maintainer may already have addressed some of these security concerns with specific patches, without actually adding any of the new features of the newer versions. For example, may tell you that you should have at least version 2.14 of a package, but it only detects version 2.10. If your version came from a package maintainer, though, that "2.10" may actually include all of the security fixes from 2.14, but not any additional features. For that reason, the package maintainer can't call his version "2.14", but it may still be just as secure as 2.14. In short, if you get your packages from a package maintainer (rather than installing them by hand, or via CPAN), you shouldn't be too concerned about version problems that reports, as long as you have the latest versions of these packages from the maintainer.

Last modified 17 years ago Last modified on Apr 25, 2006, 6:25:53 PM