Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#61 closed defect (fixed)

rss feed needs https link

Reported by: dmorton Owned by: rjl
Priority: normal Milestone:
Component: Website Version:
Severity: normal Keywords: rss feed https
Cc:

Description

the rss feed goes to http:// ... in which trac gives an error.

Change History (8)

comment:1 Changed 16 years ago by rjl

  • Keywords rss feed https added
  • Status changed from new to assigned

Which URL specifically are you referring to? The orange "XML" icon and "(RSS 2.0)" links appear to point to the proper https:// URL, as I just verified on the View Tickets, Browse Sources, and Timeline pages. Is there another location RSS feeds are referenced?

comment:2 Changed 16 years ago by rjl

This appears to be a Trac-related bug that was reported to their developers just today:

<http://projects.edgewall.com/trac/changeset/935>

Looks like they hard-coded "http:" into their XML.

comment:3 Changed 16 years ago by rjl

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed by manual patching of the affected files. All RSS feeds should now generate "https://" URLs.

comment:4 Changed 16 years ago by dmorton

  • Resolution fixed deleted
  • Status changed from closed to reopened

Now all links point to https://www.renaissoft.com/ but not to individual articles. That's not the expected behaviour, is it?

comment:5 Changed 16 years ago by rjl

  • Resolution set to fixed
  • Status changed from reopened to closed

See TracRss. The Timeline and View Tickets feeds are intended to list the complete set of items, not specific entries. The Browse Source feed is the only one that's intended to be file-specific.

As a footnote, Thunderbird 0.8's RSS support doesn't like Trac's RSS, complaining that it's an "invalid RSS feed", probably because Thunderbird doesn't yet support RSS 2.0. The feed works fine with Firefox's Sage extension, though.

comment:6 Changed 16 years ago by rjl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Okay, I think I see what you're referring to now. The RSS feeds do contain the full list of items, but the item links themselves don't seem to be correct for some reason, just pointing to https://www.renaissoft.com/. I'll take another look at the Trac code.

comment:7 Changed 16 years ago by rjl

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed. Finally :)

comment:8 Changed 16 years ago by dmorton

yup, that's what I was trying to get at. :)

Note: See TracTickets for help on using tickets.