Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#314 closed defect (fixed)

PEAR::Net_SMTP complains if PEAR::Auth_SASL is not installed

Reported by: rjl Owned by: rjl
Priority: normal Milestone: 1.0.2
Component: PHP scripts Version: 1.0.0
Severity: normal Keywords: PEAR::Net_SMTP PEAR::Auth_SASL configtest.php


Older versions of PEAR::Net_SMTP require that PEAR::Auth_SASL be installed, even if authentication is not required. Newer versions of PEAR::Net_SMTP (1.2.5+) test properly for the presence of PEAR::Auth_SASL, such that it's treated as an optional module, as intended. Configtest.php needs to increase the minimum required version number for PEAR::Net_SMTP to 1.2.5 to avoid these earlier versions.

Change History (2)

comment:1 Changed 10 years ago by rjl

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [1032].

comment:2 Changed 10 years ago by rjl

It looks like the latest version of Net_SMTP (1.2.8) no longer considers Auth_SASL to be optional, so as of [1034] configtest.php considers Auth_SASL to be a required module as well.

Note: See TracTickets for help on using tickets.