Opened 13 years ago

Closed 13 years ago

#265 closed defect (fixed)

Bypassing filtering for oversized items doesn't behave as intended

Reported by: rjl Owned by: rjl
Priority: high Milestone: 1.0.1
Component: amavisd-maia Version: 1.0.0
Severity: normal Keywords: size limit oversized bypass
Cc:

Description

Paul Westbrook reports that amavisd-maia's size limit feature is not properly bypassing processing for oversized items. In fact, it /does/ bypass /filtering/ as intended, but it unnecessarily decodes MIME attachments and unpacks them, so the process should certainly be tweaked to avoid this unnecessary use of resources.

Change History (2)

comment:1 Changed 13 years ago by rjl

  • Milestone set to 1.0.1
  • Priority changed from normal to high

comment:2 Changed 13 years ago by rjl

  • Resolution set to fixed
  • Status changed from new to closed

Improved in Changeset 967. Oversized items no longer consume any significant memory resources, as they are not recopied internally. MIME parts of oversized items are no longer decoded (though the MIME structure is still deconstructed and reconstructed as necessary to insert/alter certain mail headers), so no attempt will be made to unpack archives or examine the contents.

Note: See TracTickets for help on using tickets.