Opened 14 years ago

Closed 10 years ago

#251 closed enhancement (wontfix)

language editing in place

Reported by: dmorton Owned by: rjl
Priority: normal Milestone: 2.0.0
Component: General Version:
Severity: normal Keywords:
Cc:

Description

A nice way to encourage language edits would be to have a debug option which when set, creates a link with or next to every locale string displayed. When the link is clicked , the translator is taken to a screen or popup that shows the current translations and allows the translator to enter a new translation.

This would be tied in with a more comprehensive update to I18n and L10n stuff.

Change History (2)

comment:1 Changed 13 years ago by dmorton

  • patch set to 0

#473 was a duplicate of this message, but has some comments that might be

pertinent. Another route would be to jsut have a special admin page to list all the keys and values

comment:2 Changed 10 years ago by mortonda@…

  • Resolution set to wontfix
  • Status changed from new to closed

I found a tool that allows this pretty easy: http://phplangeditor.mozdev.org/

From there, finding changes would be a matter of looking at the change history of the en locale files.

Note: See TracTickets for help on using tickets.