Opened 15 years ago

Closed 15 years ago

#168 closed defect (fixed)

implode() error in welcome.php

Reported by: dmorton Owned by: dmorton
Priority: normal Milestone: 1.0.0 RC6
Component: PHP scripts Version: 1.0.0 RC6
Severity: normal Keywords:
Cc:

Description

From Jan Arve Nygård:

I discovered another error when browsing one of the domain accounts
I administer. When I impersonate that domain account I get the following
error:

Warning: implode(): Bad arguments. in /var/www/mail/welcome.php on line 272
Warning: implode(): Bad arguments. in /var/www/mail/welcome.php on line 274
Warning: implode(): Bad arguments. in /var/www/mail/welcome.php on line 276
Warning: implode(): Bad arguments. in /var/www/mail/welcome.php on line 278

Change History (5)

comment:1 Changed 15 years ago by fergrorke@…

The same error messages comes up on my system each time there is a login, whether as a user or administrator. I haven't detected any functional impact thus far.

comment:2 Changed 15 years ago by fergrorke@…

Sorry. There is of couse a functional impact: The bottons to change protection levels on the Welcom page don't work.

comment:3 Changed 15 years ago by dmorton

I can't reproduce it here... Can you give some environment details?

comment:4 Changed 15 years ago by fergrorke@…

I don't think my system's particularly unusual, basically Debian Testing (a.k.a Sarge. Apache 2.0.52, PHP 4.3.10-2, PEAR 1.3.2, MySQL 4.1.9, Courier IMAP 3.0.8-3 .. and of course 1.0.0 RC6 devel copied from the trunk last week. Anything else I can usefull tell you? The one thing I did have to fiddle with a little during installation was someting in auth.php -- it didn't properly reflect where Debian likes to put IMAP.php but that was not too hand to figure out and would have any relation to this problem I think.

Regards Fergus

comment:5 Changed 15 years ago by fergrorke@…

  • Resolution set to fixed
  • Status changed from new to closed

Turns out my config.php was missing the entire $protection variable section. I have no idea why, but I pasted in the default settings and the problem has now disappeared.

Note: See TracTickets for help on using tickets.