Opened 16 years ago

Closed 16 years ago

#117 closed defect (invalid)

php5 & jpgraph

Reported by: david.smalley@… Owned by: rjl
Priority: normal Milestone:
Component: PHP scripts Version: 1.0.0 RC5
Severity: normal Keywords:
Cc:

Description

Hi,

I've got Maia successfully running under php5 (needed for mysqli extension, or at least thats the only way I could get it working)

However, with this setup I cannot get jpgraph to work, I installed JPgraph 2 alpha as this is the only version that works with php5. However now I am not getting any graphs and if I run configtest.php then I only get

"JpGraph? Error" General PHP error: var: deprecated. please use the public/private/protected modifiers

Is there any support for this setup planned? or is there a work around/error on my part that can fix it.

Thanks

Change History (1)

comment:1 Changed 16 years ago by rjl

  • Resolution set to invalid
  • Status changed from new to closed

Graphical chart support is not implemented yet, so there's no code that makes use of JpGraph? at this time. The configtest.php script tests for it as a preparatory measure, but not finding it is not serious at this point.

As for PHP5 and JpGraph? support, that's a matter to take up with the JpGraph? folks, who will, I'm sure, be refining their alpha version to work with PHP5.

There's certainly no <i>need</i> to use PHP5 to get Maia working--it's been working fine with PHP4 for a year and a half. If you've been encountering problems with PHP4 and Maia, you may be better off working to resolve those than resorting to PHP5 (which is still quite new and untested with Maia).

Note: See TracTickets for help on using tickets.