Opened 16 years ago

Closed 16 years ago

#114 closed defect (fixed)

Installing maia using fedora 3. Having issues with pear:DB and Pear:log

Reported by: jlitzelman@… Owned by: rjl
Priority: highest Milestone:
Component: PHP scripts Version: 1.0.0 RC5
Severity: critical Keywords:
Cc:

Description

Both Pear:DB and Pear.Log installed but configtest.php not recognizing this. Pear:DB is 1.6.8 and pear.log is 1.8.6 (each list as stable in pear list). However, both are listed as "not installed, please run pear install ... (name of module). I tried to install it again using "pear install db" and system respondes already installed. I even tried "pear upgrade db".. Upgrade went fine. However, configtest.php still responses with error.

One note, I have MYSQL 3.2.3 installed instead of MYSQL 4.0 because I cannot find an RPM for MYSQL 4.0.. Could this be the issue or is this not related?

Attachments (1)

maia_php_error.rtf (1.6 KB) - added by jeff litzelman 16 years ago.
php responses Pear list

Download all attachments as: .zip

Change History (6)

Changed 16 years ago by jeff litzelman

php responses Pear list

comment:1 Changed 16 years ago by rjl

I've tried to reply to you directly, but evidently you're not receiving my responses. Hopefully you're checking this ticket.

You may have multiple PEAR registries installed on your system, particularly if you've installed PHP and PEAR multiple times in different ways (e.g. from an RPM first, then later from source). A few things to check:

(1) Find out where PHP is looking for its php.ini file. Put:

<?php phpinfo(); ?>

in a file by itself and give it a .php extension, e.g. phpinfo.php. Load this file in a web browser and you should get some detailed diagnostics about your PHP installation. If you can give me the URL to this page, I can look it over and see if I can spot anything amiss.

(2) Check your php.ini file (probably /etc/php.ini or /usr/local/etc/php.ini, depending on how you installed PHP) and look for the include_path directive. What is include_path set to? Is your PEAR directory found in any of the directories in that path list? That is, is there a directory called "PEAR" in any of those directories?

(3) From the command line, type "pear config-show" and tell me what you get, particularly the setting for php_dir.

comment:2 Changed 16 years ago by jlitzelman@…

Do you have any other suggestions. I guess I can try reloading redhat 9.0 instead of fedora 3.

comment:3 Changed 16 years ago by rjl

From my latest e-mail response to you:

While I list MySQL 4.0 as the minimum requirement for Maia, it should still work with 3.x, provided your version can use InnoDB tables (more recent 3.x series came with InnoDB support). If you were able to create the database schema using the maia-mysql.sql script, you've got InnoDB support.

Really, I think there's got to be something else going on. Some other things to try:

(1) When you run the Perl version of the configuration tester--configtest.pl--does it end with "Database DSN test: PASSED"?

(2) Have you GRANTed permission to your amavis user to access your Maia database (as described in Step 2 of the installation instructions <http://www.maiamailguard.com/install.php>?

(3) Can you login to MySQL from the console using the amavis user's credentials, e.g. "mysql -u amavis -p maia"?

If you pass all three of these tests, your database would appear to be fine, which would then point us back to PHP and PEAR, but at least we'd know what we can eliminate as problem sources.

comment:4 Changed 16 years ago by anonymous

Theres just a problem with selinux not permitting access to the .lock file in the pear directory..

Maia works fine - see the users mailing list.

comment:5 Changed 16 years ago by dmorton

  • Resolution set to fixed
  • Status changed from new to closed

I think this was a combination of selinux as mentioned above, and permissions on the smarty template permissions. (Mostly selinux) Closing, as I think this is working now. Thanks to everyone who helped track this down.

Note: See TracTickets for help on using tickets.